The Chatbox

cornishman

The Coder
Staff member
#1
As some of you may have noticed, the site has been experiencing frequent "slow-downs" where everything seems to load very slowly.
It wasn't until today that I have been able to run a number of tests and discovered to my horror that most of the slow down has been due to the way the current chatbox runs.
Short explaination: The chatbox uses far too many resources!
Longer explaination: When the chatbox loads/refreshes/posts a chat it refreshes up to 32 seperate java scripts every time, it also auto-refreshes every couple of minutes, reloading all those scripts.

CURE: I am going to install a new chatbox (with gentle sound alerts) tomorrow morning (Thursday 13th March) which will work in exactly the same way as the current one, though it may not look quite the same.

I really am sorry for all the messing about I have caused you all, but hopefully this will be the last for a while.
 

Pearl

Super Moderator
Staff member
#2
I won't moan or complain about having yet another change! But I know where you live so watch it ! :46:

But seriously, thank you for your hard work. I did notice it was running slow of later but didn't want to say anything in case you thought I was moaning :biggrin::biggrin:
 

Dennisbn514

Well-Known Member
#7
Much Faster

I think Tony deserves another "atta boy" for finding and changing the chat function. The whole site seems faster when loading now.
 

cciaffone

Well-Known Member
#8
Having worked in the computer industry since about 1967,
I am a bit of a dunce with some of this new stuff.

For example, I can no longer figure out how to send a message
on the chat box, nor does the chat box tell me who's on
as it did just t'other day.

(Wish it could be left alone just long enough for me to learn it before it changes again.)
 

cciaffone

Well-Known Member
#9
hokay! played about a bit and found that if I enter some
text into the long, blank, UNLABELLED box and click SHOUT
it works. Silly me. How obvious.
 

cciaffone

Well-Known Member
#11
Thanks Pearl. Can't see a way to make myself invisible,
but no worries.

I seem to only appear in the side box when I
am actually posting (shouting???) then I vanish until
I shout again. Guess you stay in the chat box ONLY while
actually typing and hitting shout???
 

ickysna2

Well-Known Member
#14
I thought that the chatbox had been removed after the problems we had experienced because it disappeared yesterday. I switched my theme from Totally Pro back to
Default and there it was. I guess it is not showing on the Totally Pro theme on my computer unless I did something to it. :confused:
 

maltrab

Administrator
Staff member
#15
I thought that the chatbox had been removed after the problems we had experienced because it disappeared yesterday. I switched my theme from Totally Pro back to
Default and there it was. I guess it is not showing on the Totally Pro theme on my computer unless I did something to it. :confused:
Thanks for pointing that out,see if we can get it fixed
 

maltrab

Administrator
Staff member
#18
Hi John
You may of missed my earlier post today regarding trialling a mobile theme,it covers all the android and apple products,to make the forum easier to access on a mobile device using a stripped down theme,once logged in you can change the theme back to anything you like
Terry
 

onyx(John)

Super Moderator
Staff member
#19
Hi John
You may of missed my earlier post today regarding trialling a mobile theme,it covers all the android and apple products,to make the forum easier to access on a mobile device using a stripped down theme,once logged in you can change the theme back to anything you like
Terry
Hi Terry, I cant see where to change the theme. When I click on the Default Style button, it seems to just refresh the page.
I have logged out and in again, no joy.
 
Last edited:
Top